Sunday, December 29, 2019

EIGRP

Enhanced Interior Gateway Routing Protocol: 
  • advance distance Vector routing protocol supporting large networks
  • Very fast convergence time
  • supports Bounded Updates where "network topology change updates" are only sent to routers affected by the change
  • messages are sent using multicast
  • automatically performs equal cost load balancing on up to 4 paths by default; can be increased up to 16
  • EIGRP is the only protocol that can perform UnEqual Cost load balancing
Standard Configuration:
  
    R1(config)#router eigrp 100
  • '100': example of an Autonomous System (AS) and all EIGRP routers need the same AS number to peer with each other
   R1(config-router)#network 10.0.0.0  0.0.255.255
  • The network command uses a wildcard mask format which is the inverse of the subnet mask - subtract each octet by 255 to calculate.
    • subnet mast of 255.255.0.0 equals wildcard mask of 0.0.255.255
    • and 255.255.255.252 equals wildcard mask of 0.0.0.3
  • If you don't specify the wildcard mask (#network 10.0.0.0), the command defaults to a classful boundary (A, B, or C)
  • Network Command means:
    • look for interfaces that fall within this IP range
    • enable EIRGP on those interfaces, send out and listen for EIGRP hello messages and peer with adjacent EIGRP routers
    • advertise the network and mask which is configured on those interfaces
    • R1(config-router)#network 10.0.0.0 
      • You can also enter these very specifically with:
        • R1(config-router)#network 10.1.0.0  0.0.0.255
        • R1(config-router)#network 10.0.1.0  0.0.0.255
        • R1(config-router)#network 10.0.2.0  0.0.0.255
      • Or you can also specify the interface address /32, note that the router will advertise the network on the interface which is /24, not the /32 address.
        • R1(config-router)#network 10.1.0.1  0.0.0.0
        • R1(config-router)#network 10.0.1.1  0.0.0.0
        • R1(config-router)#network 10.0.2.1  0.0.0.0
    • R1(config-router)#network 10.0.0.0  0.0.255.255 
Verification Commands:

  R1#show run | section eigrp
  R1#show ip protocols
  R1#show ip eigrp interface brief
  R1#show ip eigrp neighbor
  R1#sh ip eigrp topology  (displays Successors and Feasible Successors)
  R1#sh ip eigrp topology all-links  (displays S, FS and non Feasible Successors)
  R1#show ip route   ( (D) is the eigrp designation)

RouterID 
  • EIGRP routers identify themselves to each other with an ID that looks like an IPv4 address
  • This ID will default itself to the highest loopback IP address and if none configured, to the highest interface address
  • Loopback interfaces never go down, therefore, best practice is to have a loopback on your router or manually set the Router ID
    • R1(config)#router eigrp 100
    • R1(config-router)#eigrp router-id 2.2.2.2
      • if other router interfaces are already up, you must disable/enable eigrp for the ID to take effect or reboot router
Manual Summarization 
  • Auto-Summary is by default off for EIGRP on all new IOS 
  • Manual summary routes can be used to reduce router load as only the summarised routes are advertised, not all routes
  • R2(config-router)#interface fa1/0
  • R2(config-if)#ip summary-address eigrp 100 10.0.0.0 255.255.0.0
  • R2(config-router)#interface fa0/0
  • R2(config-if)#ip summary-address eigrp 100 10.1.0.0 255.255.0.0

Passive Interface Config 
  • R2(config)#router eigrp 100
  • R2(config-router)#passive-interface loopback 0
  • R2(config-router)#passive-interface gi0/0
Default Route Injection
  • R4(config)#ip route 0.0.0.0  0.0.0.0  203.0.113.2
  • R4(config)#interface fa0/0
  • R4(config-if)#ip summary-address eigrp 100 0.0.0.0 0.0.0.0

EIGRP Successors and Feasible Successors:

  • EIGRP receives routes from its neighbors with the neighbors metric to a distant network. This is the Reported Distance  or Advertised Distance
  • It then adds that metric to the distant network, to its own metric to reach the neighbor for the total metric. This is the Feasible Distance.
  • If multiple routes are available, the best makes it into the routing table. This is the Successor Route.
  • If a 'less than best' Feasible Distance route can meet certain criteria to qualify, they can be stored as a backup route, known as a Feasible Successor
  • If a Successor Route fails, the Feasible Successor is immediately added to the routing table, no need to query all other neighbors.
    • A route qualifies as a Feasible Successor if its Reported Distance is lower than the Feasible Distance of the current Successor Route.


             R2#sh ip eigrp topology  (displays Successors and Feasible Successors)
             R2#sh ip eigrp topology all-links (displays S, FS and non Feasible Successors)

    Metric - EIGRP Calculation
    • EIRGP can consider various link characteristics to calculate its metric like Bandwidth, Delay, Reliability, and Load
    • The calculation is insane with five different "K" values multiplied and divided by B,D,R, and L.
    • The short formula is 256* (inverted bandwidth + delay); therefore, high bandwidth + lower delay  = lower (better) metric.
    • Lower metric routes are preferred, but you can manipulate the bandwidth or delay on the interfaces thus changing the metric value....NOTE - changing the delay is preferred as altering the bandwidth can affect other things in the router ...like Qos.
      • R1(config)#interface fa0/0
      • R1(config-if)#bandwidth 768
      • R1(config-if)#delay 1000  (tens of microseconds)
        • ...BW 768 Kbits/sec, DLY 10000 usec, (microseconds)
    • NOTE: changing the Bandwidth or Delay does not affect the physical properties of the interface, it only affects the software policies such as this EIGRP metric



    Saturday, December 28, 2019

    RIP

    I'm at my favorite coffee house this evening getting RIPped! I had an amazing barista make a blended espresso...so good!

    RIP the Routing Information Protocol

    • is a Distance Vector routing protocol using Hop count as its metric, 15 hops maximum
    • it will perform Equal Cost Multi Path, for up to 4 paths by default
    RIPv1                                              * RIPv2
      • is a legacy protocol                     * Both versions are still supported by Cisco
      • does not support VLSM               * supports VLSM (subnetting)
      • every 30 sec. broadcast updates  *uses multicast address 224.0.0.9
      • no route authentication                *supports authentication
        note: RIPng (RIP next generation) supports IPv6 networks

      RIPv2 Configuration
        R1(config)# router rip
        R1(config-router)# version 2
        R1(config-router)# network 10.0.0.0
            * the "network" here is classful (/8), so no need for a subnet mask
            * by default RIPv2 uses Auto-Summary along the classful boundary
               𛲡 ex 192.168.10.1/30 will be advertised at 192.168.10.0/24
               𛲡 ex  172.16.10.1/30  advertised at 172.16.0.0/16
        R1(config-router)# no auto-summary    (removes the above)

           * if summarization is needed you can manually define it
           * the summarized route is configured on the interface that should advertize the route
        R2(config-router)# interface f1/0
        R2(config-if)# Ip summary-address rip 10.0.0.0  255.255.0.0

        Handy commands:
           R1#show ip protocols   (this will show all routing protocols on the router)
           R1#show run | section rip  
           R1#show ip route
           R1#show ip rip database

      Advanced concepts:
      Passive interfaces in all other IGPs do not send out or listen for routing updates. And the network on these interfaces must be manually configured into the routing table to be shared with peer routers.
          RIPs passive interfaces do not send out updates but do listen to incoming updates from other RIP speaking neighbors. the router can receive updates on the passive interface and use them in the routing table. 
        R1(config)#router rip
        R1(config-router)# passive-interface loopback 0   (best practise)
        R1(config-router)#passive-interface fa2/0 (port connects to external company)

        Alternatively, make all ports on the router passive and then specify the interfaces that are not passive.
        R1(config)#router rip
        R1(config-router)# passive-interface default
        R1(config-router)#no passive-interface fa0/0
        R1(config-router)#no passive-interface fa1/0

      Default Router Injection:  used to configure a default route on the router with the "internet connection" and force it to all other routers in the network.
        R4(config)#ip router 0.0.0.0 0.0.0.0 203.0.113.2  (standard static route)
        R4(config)#router rip
        R4(config-router)# default-information originate

      RIP Default Timers
      • Update: The router sends updates every 30 seconds.
      • Invalid: After no updates for 180 seconds the route becomes invalid
      • Hold Down: this timer is used to stabilize the network and starts when the invalid timer completes. During this timer, no new routes are accepted, even if they have better metrics
      • Flush: 240 seconds from the last update the route is flushed.

      • The timers can be changed to achieve faster convergences but if too short they can introduce instability. All routers in the network must have the same timers
        •   R1(config)#router rip
        •   R1(config-router)#timers basic 10 90 90 120

      Friday, December 27, 2019

      Connectivity Troubleshooting

      Today, played a little catch with Rowan, the went to a new coffee shop in Shreveport called MOOR Coffee Co (they have a good cappuccino but the shop has a kids playroom adjacent - which can be a little noisy)

      Troubleshooting
      • ICMP: Internet Control Message Protocol (PING
        • sends out an Echo Repay testing two-way connectivity
        • Use the Extended Ping option if you need to send out the ping from a different IP interface than the exit IP interface on a router
      • Traceroute (TR): this using PING and utilizes the TTL field
        • Time To Live is a mechanism to minimize network loops by setting the maximum of hops a patch can travel
          1. TR sends the first PING with a TTL of 1 and the first hop will reduce the TTL to 0, then drop the packet, and send back a "time exceeded" reply. 
          2. TR then sends the second PING with a TTL of 2 and the second hop does the same as the first hop.
          3. This continues and builds a visual route the patch is taking until the PING gets to its final destination.
          4. NOTE: to abort the TR press Ctrl-Shift-6
      • Layer 1 - Other tools
        • Show ip interface brief
        • Show interface
      • Layer 2
        • show arp
        • show mac address-table 
      • Layer 4
        • Telnet - telnet to a destination ip address with the port number to see if it answers
      • Other Tools - to test DNS
        • nslookup
        • Ping by FQDN  (ping www.cisco.com)
      Cisco IP SLA
      • is an active traffic monitory feature of IOS to measure network performance
      • it can generate traffic that mimics normal production traffic to report performance characteristics such as latency, jitter, and loss
        • R1(config)#ip sla 1    (you can set up multiple)
        • R1(config-ip-sla)#icmp-echo 10.1.2.10   (set the destination address)
        • R1(config-ip-sla-echo)#frequency 10   (every 10 seconds)
        • R1(config-ip-sla-echo)#exit
        • R1(config)#ip sla schedule 1 life forever start-time now
        •      
        • R1#show ip sla statistics  (view anytime or send to reporting server)

      Monday, December 23, 2019

      Routing: Dynamic Protocols

      2 days until Christmas 🎅, and the fam went to see Star Wars: Rise of Skywalker....and it was OK. However, there were many protocol droids!

      Dynamic Routing Protocols

      • Routers automatically advertise their best paths to known networks
      • Routes use this info to determine their own best path to known networks
      • Routes update each other of network changes
      • And automatically calculate new best paths
               RIP: Routing Information Protocol
               EIGRP: Enhanced Interior Gateway Routing Protocol
               OSPF: Open Shortest Path Protocol
               IS-IS: Intermediate System- Intermediate System
               BGP: Border Gateway Protocol
          IGPs are for routing within an organization
      • Distance Vector only form adjacencies with directly connected routers; they only share information with their directly connected neighbor; distance can be the HOP count and the vector is the direction to send the patch; simple configuration; low CPU untilizaiton; slow convergence
        • #sh ip rip database   shows all routes it has learned form the neigbors POV
        • #sh ip rip    show the best routes that will be used
      • Link State also form adjacencies.... and gather infomations from routers to form a complete network topology; based on the "cost" of the links, complexer configs; higher CPU unilization; faster convergence
          EGPs are for routing between organizations over the Internet


      Metric: each possible path will be assigned a 'metric' value by the routing protocol which indicates how preferred the path is - '0' being best. Then the routing protocol independently calculated its own best path to each destination.
         If the best path is lost (like a link with down) it will be removed from the routing table and replaced with the next best route.

      • RIP uses Hop count with default max metric of 15; it has scalability limitations.
      • EIGRP is simple to maintain, calculated changes quickly and its metrical calculation will normally choose the best path by default, was Cisco proprietary. 
      • OSPF metric calculation is by default chosen as best path. It is an open standard but more complicated to maintain than EIGRP.
      • IS-IS links need to be manually configured or it will us hop count to determine the best path. It typically is only used in Service Provider networks or large organizations with their own MPLS network. 
      ECMP (Equal Cost Multi Path)
      • if multiple paths to a destination have an equal metric, the router will enter all of the paths into the routing table
      • ECMP will load balance the outbound traffic to the destination over the different paths
      • All IGP routing protocols will ECMP by default, however, EIGRP can also do UnEqual Cost Multi Path, if manually configured do to so.
      Administrative Distance
      • If paths to the same destination are received by different routing protocols, their metrics can not be compared. The router uses a different method to choose the best path, and that is the Administrative Distance (AD).
      • The AD is a measure of how trusted the routing protocol is and the lower the value wins.
      • AD is considered first to narrow the choice down to the single best routing protocol
      • Then the Metric is considered to choose the best path or paths which make it into the routing table.

      Floating Static Routes - changing the AD value for static routes

      • If routes populated by a routing protocol are preferred, and you wanted a backup static route in the table, you would need to override the static default of "1"
      • #ip route 10.0.1.0 255.255.255.0 10.1.3.2 115
      Loopback Interface - logical interface↛ not physical
      • Loopback interfaces are commonly used for traffic that terminates on the router itself, like management traffic, BGP peering, etc.
      • The provides redundancy if there are multiple paths to a router, an example is if you are using an IP address on a router interface for management....and that interface goes down ⇏ you would not be able to manage that router.
      • The loopback is also used to identify the router (Router ID) in OSPF.
      • You must create the logical interface, add an address, and advertise it in the routing protocol.
      • (config) interface lookback 0
      • (config-if) IP address 192.168.1.1 255.255.255.255 (/32- not waisting IP address')
      • (config-if) router eigrp 100   (assign Lookback to existing routing protocol)
      • (config-router) network 192.168.1.1 0.0.0.0 (wildcard mask that is the inverse of the subnet mask)
      Adjacencies - when an IGP routing protocol is configured globally on a router and then enabled on individual interfaces, the interfaces will look for directly connected devices that are also running this protocol to then form an adjacency and then exchange routing information. Modern routing protocols use multicast to send hello packets.

      Passive Interfaces - they do not send out or listen for routing updates: allows you to include an IP subnet in the routing protocol without sending updates out of the interface, so if you need connectivity to another network, but don't want to send internal network information to this network that might belong to another organization. 
      Also, loopback interfaces should be configured as passive interfaces, no need wasting resources sending out and listening for hello packets to a dead end (you can not connect other routes to the loopback interface), however, this interface will be advertised by the routing protocol.

      Sunday, December 22, 2019

      Routing: Local & Static


      Local Routes - these are directly connected networks and are learned when the interfaces are configured; "C" =connected route
               sh ip route 
      C 10.0.0.0/24 is directly connected, FastEthernet 0/0  (displays the network)
      L  10.0.0.1/32 is directly connected, FastEthernet 0/0 (displays the IP address)

      Static Routes - manually input routes to networks not directly connected.
      R1(config t)#ip route 10.1.0.0  255.255.255.0  10.0.0.2
                       #ip route 10.1.1.0  255.255.255.0  10.0.0.2 
                       #ip route 10.1.2.0  255.255.255.0  10.0.0.2 <--the adjacent hop that is directly connected)

      Route Summarization  (for static routing) reduces administrative overhead and memory usage.
             R1(config)# Ip route   10.1.0.0 255.255.0.0 10.0.0.2 (this is huge addresses to summarize)

          To tighten, summarize this range of 10.1.0.0  to  10.1.3.0 (subnet the third octet)
             R1(config)# ip route  10.1.0.0  255.255.252.0  10.0.0.2


      Longest Prefix Match (subnet mask) - if a destination address matches more than one routing path, the router will always choose the most specific route.
         R1 /# ip route  10.1.0.0  255.255.0.0      10.0.0.2  (this covers all networks)
         R1 /# ip route  10.1.3.0  255.255.255.0  10.0.3.2  (more specific for the 10.1.3 network)

      Load Balancing - if there are matching routes with difference paths, the router will load balance the traffic.
      R1# ip route  10.1.0.0   255.255.255.0  10.0.0.2
      R1# ip route  10.1.0.0   255.255.255.0  10.0.3.2 

      Default Route (Gateway of Last Resort) -  205.5.42 <-- internet connection
         R1 /# ip route  10.1.0.0  255.255.0.0      10.0.0.2  (this covers all known networks)
         R1 /# ip route  10.1.3.0  255.255.255.0  10.0.3.2  (more specific for 10.1.3 network)
         R1 /# ip route  0.0.0.0    0.0.0.0             205.5.4.2 (captures every else)


      Note: routers Ping command always uses the  exit interface, so to "ping" from another interface - use the "extended ping" -->router# ping   or   router# traceroute

      Saturday, December 21, 2019

      Device Management


      4 days until Christmas 👍, and I 'm trying to get a few lessons in before the Chapman Family party today. Putting a little Grizz coffee in the bear!

      Router Memory
      1. ROM - powering on loads from ROM first and performs (a) Power On Self Test (POST)- checking for any problems with the hardware, the (b) Loads Bootstrap- looks in Flask for IOS software to load, if no IOS present, the device will boot to the ROMMOM prompt and the image could be pulled from TFTP or a USB
      2. Flash Memory - device will load the first IOS image found by default, you can override this with the (config t) boot system......
      3. NVRAM (Non-Volatile RAM) - this is where the startup-config file is located; if not present the device will load the Start Wizard
      4. RAM - working memory of the device; IOS from Flash and the Startup-config from NV-RAM are loaded into the RAM at startup

      Factory Reset
      Router> write erase  this deletes the NVRAM -->  the startup-config

      Password Recovery 
      Config-Register  is used to change the way the device boots
      0x2102: boots normally (default)
      0x2120: boot into rommon
      0x2142: ignore contents of NVRAM (startup-config)
      (config t) config-register 0x2142

      1. Reboot device, press Ctrl-Break at power on to break into rommon
      2. rommon> confreg 0x2142 (this will ignore startup-config on boot)
      3. rommon> reset (this will reload device with no config, however, the original config is still in NVRAM with the unknown enable secret password)
      4. Type "no" to bypass the setup wizard
      5. Enter "enable" mode - device will not prompt for enable secret as there is not one in the running configuration.
      6. router# copy startup-config running-config - NOTE: you are already in enable mode :-)
      7. router (config t)# enable secret  xxxxxxx (Enter new enable secret to over right old one)
      8. router (config t)# config-register 0x2102 (device will boot normally at next restart)
      9. router# copy running-config startup-config 

      Backing up System Image and Config
      • router# copy flash tftp   (prompted for file name of IOS image in flash to copy, then address of tftp server)
      • router# copy running-config tftp  (prompted to give new name to running-config, and address of tftp server)
      • Note: if you copy anything to running-config…it will just merge with running-config
      • Back up config to flash and restore -
        • router# copy running-config flash  (now we have a backup)
        • router# write erase    (delete startup-config)
        • router# copy flash startup-config
        • router# reload

      Upgrade IOS
      1. Download new IOS from Cisco to TFTP
      2. router# copy tftp to flash
      3. The old IOS could be deleted, and at reload the new IOS is the only file to load
      4. To keep the old IOS at a backup, must change the boot system
      5. router (config t)# boot system flash: (file name in flash)
      6. router# copy running-config startup-config
      7. router#reload
      IOS Licensing
      1. After purchasing a license to unlock a feature on your device, Cisco will provide a Product Activation Key (PAC).
      2. Enter the PAC at (cisco.com/go/license) with the UDI (Unique Device Identifier) to create the license file.  Note: license tied to device
      3. Load the file to Flash, then install
      • Router (config t) license install flash: (file name)
      • Router# show license  (note: to display UDI - r1#show License udi)

      Monday, December 16, 2019

      Router & Switch Basics with Crème brûlée

      In Houston with Nick Faul and Nick McKinney at Tout Suite coffee/cafe house, because in networking 2 Nicks are always better than 1.



      Router IP assignment
      (config terminal) interface Fastethernet0/1;
      (config if) ip address 192.168.1.1   255.255.255.0;
      no shutdown

      Switch IP assignment is on VLAN 1 (this is a Switch Virtual Interface SVI) -
      (config terminal)Interface VLAN 1;
      (config if) ip address 192.168.1.10   255.255.255.0
      (config if) no shutdown   (not necessary on a switch but a good habit)
      (config t) ip default-gateway 192.168.1.1     (is the switch need connectivity to and from other networks)

      (config t) hostname SW1
      (Config t) interface FastEthernet 0/1
      (config if) description Port to Router1

      (config if) speed 100   (do these for critical links between routers, SW's, & servers)
      (config if) duplex full (half)   (both of these must match on both sides of the link)

      Common commands
      Show running-config
      Show ip interface brief                        ( lists all interfaces on device)
      Show run interface FastEthernet 0/1    (only show running-config on the interface)
      Show interface FastEthernet 0/1          (shows MAC, packet totals, errors)
      Show version


      CDP (Cisco Discovery Protocol - Cisco proprietary, layer 2 protocol for only Cisco devices and software, it's enable by default but could be seen as a security concern )
      Show cdp                             (shows if CDP is enable)
      Show cdp neighbors              (show brief output of devices)
      Show cdp neighbors detail     (detailed output)
      (config t) cdp run                  (this enables cdp, but it is on by default)
      (config t) no cdp run             (disables cdp globally)
      (config if) no cdp enable        (just turns it off on this interface)

      LLDP - Link Layer Discovery Protocol - open standard, but is not available on older devices
      Show lldp                             (show if llcp is enabled)
      Show lldp  neighbors             (sh brief output of devices)
      Show lldp neightbors detail    (detailed output)
      (config t) lldp run
      (config t) no lldp run             (turns off globally)
      (config if) no lldp transmit     (interface off to transmit lldp info to other devices)
      (config if) no lldp receive       (interface off to receive lldp info from other devices)

      Sunday, December 15, 2019

      Cisco Troubleshooting Methodology & Bread





      Common tools on the router
      1. Ping - tests bidirectional connectivity
      2. Traceroute - uses the ICMP to each hop and maps the route
      3. Telenet - used to indicated if a service is running at the recipient: telenet cisco.com 53 (53 is the port number for DNS; 80 is HTTP; 443 is HTTPS…..)
      4. (PC) nslookup for DNS info - ex \nslookup www.cisco.com

      Life of a Packet (Full Meal Deal)

      Domain Name System (DNS)
      • DNS resolves Fully Qualified Domain Name (FQND) to IP addresses
      • Host send their DNS queries to a DNS server usually over UDP port 53
      • On a PC, the Nslookup command delivers FQND to IP address
        • DNS commands to set up a router client to lookup FQND
        •     #> ip domain-lookup
        •     #> ip name-server x.x.x.x
        •     #> ip domain-name letnet.net (primary domain name)
        •     #> ip domain-list letu.edu (additional DNS suffixes to search)
        • Setup router as DNS server, usually done by windows server
        •     #> ip dns server
        •     #> ip host (hostname) x.x.x.2 (address records)
        •     #> ip host (hostname.letnet.net) x.x.x.2 ; etc.



      Saturday, December 14, 2019

      Network Hardware (Meat and Potatoes)

      High overview of the hardware:
      Hubs
      • Operate in half-duplex
      • All host share the same collision domain - only one device can talk at a time
      • Hosts us Carrier-Sense Multiple Access with Collision Detection (CSMA/CD)
      • Operate on layer 1, and not MAC address aware
      Switch
      • Operate in Full-duplex or half-duplex
      • All hosts have their own dedicated collision domain
      • Collision Detection is not required
      • Operate on Layer 2; are MAC aware and build tables for directing frames
      Router
      • Route traffic between different networks (Layer 3)
      • Also, operate at Layer 2 and 1 and aware up to Layer 7
      • Interfaces types such as Ethernet, Serial, ISDN, ADSL, etc. 
      • Do not by default forward broadcast traffic like switches
      Layer 3 Switch
      • Advance switches are layer 3 aware and can route traffic between subnets
      • Usually, only support Ethernet interfaces and have more ports than a router

      Security
      • Cisco ASA - Adaptive Security Appliance) Firewalls
      • Cisco SourceFire FirePower IPS (Intrusion Prevention System) purchased as an applicate or ASA add-on module
      Wireless
      • Wireless LAN controllers and APs
      Collaboration
      • Cisco Unified Communications Manager, IP Phones, TelePresence, WebEx
      Data Center
      • Cisco UCS (Unified Computer System) - blade server
      • Nexus Switches

      Friday, December 13, 2019

      Layer 2 (Big MAC)

      The Data Link Layer  - I love this tasty layer....so beautifully simple 😁

      Leah and I are chill'in at the Grizz...nothing better than a cap and a MAC lesson
      • Frames are encoded and decoded into Bits at Layer 2
      • Error detection and correction for the Physical layer can be provided here
      • Ethernet is king of layer 2
      • Ethernet uses 48-bit hex MAC Addresses
      • The first 24 bits are OUI (Organizationally Unique Identifier) assigned my IEEE
      • Vender assigns last 24; every address is globally unique; 281 trillion possibilities 248
      • Example:  00:60:C2:C0:00:09
      Here are some other common Layer 2 protocols:
        • ARP  Address Resolution Protocol
        • ATM  Asynchronous Transfer Mode
        • CDP   Cisco Discovery Protocol
        • FDDI  Fiber Distributed Data Interface
        • Frame Relay
        • Multi-link Protocol
        • PPP    Point-to-Point Protocol
        • STP   Spanning Tree Protocol
        • VTP   VLAN Trunking Protocol
        • VLAN  Virtual Local Area Network
        https://en.wikipedia.org/wiki/List_of_network_protocols_(OSI_model)

      Thursday, December 12, 2019

      IP: RFC 1928 Private Addresses

      Memorize these:
      • 10.0.0.0  -  10.255.255.255
        • 10.0.0.0  /8
        • 10.0.0.0  255.0.0.0
      • 172.16.0.0  - 172.31.255.255
        • 172.16.0.0  /12
        • 172.16.0.0  255.240.0.0
      • 192.168.0.0  - 192.168.255.255
        • 192.168.0.0  /16
        • 192.168.0.0  255.255.0.0

      History note: The Royal Flying CorpsThe RFC was in existence from 1912 to 1918. In July 1914 the RFC's naval wing was detached to form the Royal Naval Air Service (RNAS). On 1 April 1918 the two services were merged again to form the Royal Air Force (RAF).

      Spanning Tree